hdu 1081 To The Max 基础dp

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
       
       
       
       
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
       
       
       
       
15
分析:通过转换成最大字段和
第一步:dp[i][j]=a[1][j]+ …… +a[i][j]
第二步:sum+=dp[j][k]-dp[k][i-1];
第三步:求max和sum的较大值
代码:
#include<stdio.h>
#include<string.h>
int a[102][102],dp[102][102];
int main()
{
    int i,j,k,n,max,sum;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
         {
             scanf("%d",&a[i][j]);
             dp[i][j]=dp[i][j-1]+a[i][j];
         }
         int max=-9999;
         for(i=1;i<=n;i++) //控制行
          for(j=i;j<=n;j++) //控制列
          {
              int sum=0;
              for(k=1;k<=n;k++) //控制连续的层数
              {
                  sum=sum>0?sum:0;
                  sum+=dp[k][j]-dp[k][i-1];
                  max=max>sum?max:sum;
              }
          }
          printf("%d\n",max);
    }
    return 0;
}




你可能感兴趣的:(动态规划)