计算几何——Uva 270 Lining Up

 Lining Up 

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3

思路:

对每一个点做作如下操作

以该点为坐标原点,求出剩余点相对于该点的斜率,然后排序,统计出斜率相同的点的个数。

时间复杂度为O(n2logn)

注意:

斜率不存在的点特殊处理

The outputs of two consecutive cases will be separated by a blank line.

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

#define MAXN 705
#define MAXLEN 50
#define INF 0x7FFFFFFF

int x[MAXN], y[MAXN];
double slope[MAXN];

//统计斜率相同的点的个数
int MaxCount(int n)
{
	int maxCount = 0, count = 1;
	
	int i;
	for (i = 1; i < n; i++)
	{
		if (slope[i-1] == slope[i])
		{
			count++;
		}
		else
		{
			if (count > maxCount)
			{
				maxCount = count;
			}
			count = 1;
		}
	}
	if (count > maxCount)
	{
		maxCount = count;
	}
	//加上作为坐标原点的点
	return maxCount+1;
}

int MaxNPoints(int n)
{
	int maxNPoints = 0;
	int i, j, k;
	for (i = 0; i < n; i++)
	{
		for (j = i + 1, k = 0; j < n; j++, k++)
		{
			//斜率为无穷
			if (x[j] == x[i])
			{
				slope[k] = INF;
			}
			else
			{
				slope[k] = (double)(y[j] - y[i]) / (double)(x[j] - x[i]);
			}
		}

		sort(slope, slope+k);

		int npoints = MaxCount(k);
		if (npoints > maxNPoints)
		{
			maxNPoints = npoints;
		}
	}
	return maxNPoints;
}

int main(void)
{
	int ncases;
	scanf("%d\n", &ncases);

	while (ncases-- != 0)
	{
		char buff[MAXLEN];

		int i;
		for (i = 0; gets(buff) != NULL && buff[0] != '\0'; i++)
		{
			sscanf(buff, "%d%d", &x[i], &y[i]);
		}
		int n = i;

		printf("%d\n", MaxNPoints(n));
		if (ncases != 0)
		{
			putchar('\n');
		}
	}
	return 0;
}

你可能感兴趣的:(计算几何,斜率)