DFS__1349: Oil Deposits

由于是算油井数量,当是连接在一起的时候,8个方向搜索,如果是油井就把它改成'*',这样就没后顾之忧了.

另外搜索也不需要一个数组用来保存是不是被搜索过这个问题!

Status In/Out TIME Limit MEMORY Limit Submit Times Solved Users JUDGE TYPE
stdin/stdout 3s 8192K 356 201 Standard

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise and . Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

 

#include<iostream>
char str[100][100];
int x[8]={-1,0,1,-1,1,-1,0,1};
int y[8]={-1,-1,-1,0,0,1,1,1};
int num,m,n;
void dfs(int x1,int y1)
{
     int i;
     str[x1][y1]='*';                                      
     for(i=0;i<8;i++)
     {
          if(x1+x[i]<m && x1+x[i]>=0 && y1+y[i]<n && y1+y[i]>=0 && str[x1+x[i]][y1+y[i]]=='@')
          {
    dfs(x1+x[i],y1+y[i]);
    }
 }  
}            
int main()
{
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
    int i,j;
    scanf("%d%d",&m,&n);
    while(m!=0)
    { 
             num=0; 
             for(i=0;i<m;i++)
                 scanf("%s",str[i]);
             for(i=0;i<m;i++)
               for(j=0;j<n;j++)
                  if(str[i][j]=='@')
                  {
                     dfs(i,j);
                     num++;
                  }
             printf("%d/n",num);                  
             scanf("%d%d",&m,&n);
    }          
    return 0;
}

你可能感兴趣的:(DFS__1349: Oil Deposits)