POJ 2785 4 Values whose Sum is 0(二分)

4 Values whose Sum is 0
Time Limit: 15000MS   Memory Limit: 228000K
Total Submissions: 14089   Accepted: 3975
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5


跟以前一个题目很相似,不过那个有五堆,枚举一二堆合并堆,三四堆合并堆,然后再二分第五堆。这个直接将前两堆合并为1堆,后两堆合并为一堆,枚举第一堆,二分第二堆。

   分析时间复杂度,O(4000*4000*log2(4000*4000)),不过这个是最优的时候,二分的代码写得并不好,找到边界之后需要遍历,然后依次再移动,假如合并之后a和b全为0,那时间复杂度就远远不止这点了。变为了O(10^14)........数据比较水。每次二分找的时候可以加个标记,这样时间复杂度会降下来,自己就没实现这个了。。空间也给了很大,几千万的数组是妥妥可以放的。

   题目地址:4 Values whose Sum is 0

AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[16000005];    //第一堆
int b[16000005];    //第二堆
int p[4005][4];
int t;

int erfen(int x)
{
    int cnt=0;
    int l=0,r=t-1,mid;
    while(r>l)
    {
        mid=(l+r)>>1;
        if(b[mid]>=x) r=mid;
        else l=mid+1;
    }

    while(b[l]==x&&l<t)    //依次左移
    {
        cnt++;
        l++;
    }
    return cnt;
}

int main()
{
    int n,i,j;
    long long res;
    while(cin>>n)
    {
        res=0;
        for(i=0;i<n;i++)
            for(j=0;j<4;j++)
                scanf("%d",&p[i][j]);
        t=0;
        //合并前两个数作为第一堆,后两个数作为第二堆
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                a[t++]=p[i][0]+p[j][1];
        sort(a,a+t);
        t=0;
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                b[t++]=p[i][2]+p[j][3];
        sort(b,b+t);

        for(i=0;i<t;i++)
            res+=erfen(-a[i]);
        cout<<res<<endl;
    }
    return 0;
}

/*
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
*/

//49300K	5282MS


你可能感兴趣的:(二分)