hdu2717 Catch That Cow BFS简单题

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7994    Accepted Submission(s): 2529


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
   
   
   
   
5 17
 

Sample Output
   
   
   
   
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
#include<cstdio>
#include<queue>
#include <cstring>
#define MAX 100001
using namespace std ;

struct Node{
	int pos,step ;
	bool operator <(const Node &a) const
	{
		return step>a.step ;
	}
};
int dir[2]={-1,1} , des;
int visited[MAX] ;

int BFS(int start)
{
	priority_queue<Node> que ;
	Node s;
	s.step = 0 , s.pos = start ;
	que.push(s) ;
	while(!que.empty())
	{
		Node now = que.top() ;
		que.pop() ;
		if(now.pos == des)
		{
			return now.step ;
		}
		for(int i = 0 ; i < 2 ; ++i)
		{
			int next = now.pos+dir[i] ;
			if(next<MAX && next>=0 && (visited[next]==-1 || visited[next]>now.step+1))
			{
				Node n;
				visited[next] = now.step+1;
				n.step = now.step+1;
				n.pos = next ;
				que.push(n) ;
			}
		}
		int next = now.pos*2 ;
		if(next<MAX && next>=0 && (visited[next]==-1 || visited[next]>now.step+1))
		{
			Node n;
			visited[next] = now.step+1;
			n.step = now.step+1;
			n.pos = next ;
			que.push(n) ;
		}
	}
}

int main()
{
	int s ;
	while(~scanf("%d%d",&s,&des))
	{
		memset(visited,-1,sizeof(visited)) ;
		int ans = BFS(s) ;
		printf("%d\n",ans) ;
	}
	return 0 ;
}

与君共勉

你可能感兴趣的:(搜索,catch,bfs,COW,that,hdu2717)