POJ 1258 Agri-Net(最小生成树prim算法)

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 45283   Accepted: 18599

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

 

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

 

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

 

Sample Output

28

 

题意:要实现n个农场间网络畅通,现在给出n*n的农场距离表。  第i行第j列的数即表示i农场与j农场间的距离。求出实现所有农场网络畅通的最短的总光纤长度。

 

prim算法入门题了,代码如下:

 

<span style="font-size:12px;">#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f
int map[110][110],n;

void prim()
{
	int sum=0;
	int i,j,next,min;
	int lowcost[110],visit[110];
	memset(visit,0,sizeof(visit));
	for(i=1;i<=n;++i)
	    lowcost[i]=map[1][i];
	visit[1]=1;
	for(i=2;i<=n;++i) 
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&min>lowcost[j])
			{
				min=lowcost[j];
				next=j;
			}
		}
		sum+=min;
		visit[next]=1;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&lowcost[j]>map[next][j])
			   lowcost[j]=map[next][j];
		}
	}
	printf("%d\n",sum);
}

int main()
{
	int i,j,d;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				scanf("%d",&d);
				map[i][j]=map[j][i]=d;
			}
		}
		prim();
	}
}</span>


 

你可能感兴趣的:(POJ 1258 Agri-Net(最小生成树prim算法))