HDU1395:2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

Sample Input
   
   
   
   
2 5
 

Sample Output
   
   
   
   
2^? mod 2 = 1 2^4 mod 5 = 1
 


 

//水水更健康

 

#include <stdio.h>

int main()
{
    int n;

    while(~scanf("%d",&n))
    {
        int i,t = 2,flag = 0;
        for(i = 1;i<=n;i++)
        {
            t = t%n;
            if(t==1)
            {
                flag = 1;
                break;
            }
            t*=2;
        }
        if(flag)
        printf("2^%d mod %d = 1\n",i,n);
        else
        printf("2^? mod %d = 1\n",n);
    }

    return 0;
}


 

你可能感兴趣的:(ACM,HDU)