hdu 1695 GCD 莫比乌斯反演

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7229    Accepted Submission(s): 2651


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
   
   
   
   
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
   
   
   
   
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 

Source
2008 “Sunline Cup” National Invitational Contest
 

求1到n,1到m中有多少对数字满足gcd为k。且1,2和2,1是一种情况不能重复算
相当于计算n/k,m/k的数中有多少对互质。
算出1到n,1到m中的互质情况,减去1到n,1到n中互质情况的一半就是答案
用莫比乌斯反演,用分块加速根号的复杂度
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
using namespace std;
#define maxn 100007
//记录质因数个数,
int prinum[maxn];
//每个数的u函数
int fu[maxn];
//记录是否为质数
int check[maxn];

vector<int> pri;
int call(int j,int i){
    if(j % i != 0) return 0;
    return call(j/i,i)+1;
}
void init(){
    memset(check,0,sizeof(check));
    memset(prinum,0,sizeof(prinum));
    memset(fu,0,sizeof(fu));
    //筛出质数,并计算每个数的质因数个数
    for(int i = 2;i < maxn; i++){
        if(check[i]) continue;
        pri.push_back(i);
        for(int j = i;j < maxn; j += i){
            check[j] = 1;
            if(j % (i*i) == 0) fu[j] = -1;
            prinum[j] += call(j,i);
            if(fu[j] != -1) fu[j]++;
        }
    }
    for(int i = 1;i < maxn; i++)
        if(fu[i] == -1)
            fu[i] = 0;
        else
            fu[i] = 1 - 2*(fu[i]&1);
    for(int i = 1;i < maxn; i++)
        fu[i] += fu[i-1];
}



int main(){
    init();
    int t,n,m,p,a,b,tt=1;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d%d%d",&a,&n,&b,&m,&p);
        if(p == 0){
             printf("Case %d: %I64d\n",tt++,0);
            continue;
        }
        long long ans = 0;
        n = n/p,m = m/p;
        if(n > m) swap(n,m);
        int j ;
        for(int i = 1;i <= n ;i=j+1){
            j = min(n/(n/i),m/(m/i));
            ans += 1ll*(fu[j]-fu[i-1])*(n/i)*(m/i);
        }
        long long res = 0;
        for(int i = 1;i <= n ;i=j+1){
            j = n/(n/i);
            res += 1ll*(fu[j]-fu[i-1])*(n/i)*(n/i);
        }
        printf("Case %d: %I64d\n",tt++,ans-res/2);
    }
    return 0;
}


你可能感兴趣的:(HDU,莫比乌斯反演,1695)