最短路径__Arbitrage( poj 2240 )

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No


题意:给定一些货币之间的单向汇率,问一笔钱能否经过若干次对换而增值。


思路:典型floyd判断两点之间最大汇率路径是否大于1,字符串用map处理


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <map>
#include <string>
#include <iostream>
#define N 110
#define INF 999999999
using namespace std;
double mpt[N][N];
int n,m;
map<string,int>Hash;
int main()
{
    int i,j,k,t = 0;
    int a,b;
    double c;
    string str;
    while(scanf("%d",&n),n)
    {
        t ++;
        for(i = 0 ; i < n ; i++)
        {
            cin>>str;
            Hash[str] = i + 1;
        }
        for(i = 1 ; i <= n ; i ++)
        {
            for(j = 1 ; j <= n ; j ++)
            {
                if(i == j)mpt[i][j] = 1;
                else mpt[i][j] = 0;
            }
        }
        scanf("%d",&m);
        for(i = 0 ; i < m ; i ++)
        {
            cin>>str;
            a = Hash[str];
            scanf("%lf",&c);
            cin>>str;
            b = Hash[str];
            mpt[a][b] = c;
        }
        for(i = 1 ; i <= n ; i ++)
        {
            for(j = 1; j <= n ; j ++)
            {
                for(k = 1; k <= n ; k ++)
                {
                    if(mpt[i][j] < mpt[i][k] * mpt[k][j])
                       {
                         mpt[i][j] = mpt[i][k] * mpt[k][j];
                       }
                }
            }
        }
        int ans = 0;
        for(i = 1; i <= n ; i++)
        {
            if(mpt[i][i] > 1)ans++;
        }
        printf("Case %d: ",t);
        if(ans > 0)
        {
            printf("Yes\n");
        }
        else{
            printf("No\n");
        }
    }
    return 0;
}




你可能感兴趣的:(map,最短路径,floyd)