Lake Counting
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 19975 |
|
Accepted: 10048 |
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
算法分析:DFS深度搜索问题,树形搜索。代码如下:
#include<stdio.h>
#define MAXN 101
int N,M;
char a[MAXN][MAXN];
void dfs(int x,int y);
int main()
{
int res=0,i,j;
scanf("%d%d",&N,&M);
getchar();
for(i=0;i<N;i++)
{
for(j=0;j<M;j++)
scanf("%c",&a[i][j]);
getchar();
}
for(i=0;i<N;i++)
{
for(j=0;j<M;j++)
{
if(a[i][j]=='W')
{
dfs(i,j);res++;
}
}
}
printf("%d\n",res);
return 0;
}
void dfs(int x,int y)
{
int dx,dy,nx,ny;
a[x][y]='.';
for(dx=-1;dx<=1;dx++)
{
for(dy=-1;dy<=1;dy++)
{
nx=dx+x;ny=dy+y;
if(0<=nx&&nx<N&&0<=ny&&ny<M&&a[nx][ny]=='W')
{
dfs(nx,ny);
}
}
}
return;
}