zoj2781------------------------Rounders

Introduction

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line.
Note: Round up on fives.

Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output

20
10
4
5
100
10000000
50000000
2000
500                 
 
 
逐位四舍五入即可!
代码:
 
 
#include <iostream>
using namespace std;

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		int x;
		cin>>x;
		int x1=x;
		int count=0;
		if(x<=10)
			cout<<x<<endl;
		else
		{
			while(x/10!=0)
			{
				if(x%10>=5)
					x=x/10+1;
				else
					x=x/10;
				count++;
			}
			cout<<x;
			for(;count>0;count--)
				cout<<"0";
			cout<<endl;	
		}	
	}
	return 0;
}


 

你可能感兴趣的:(Integer,input,UP,each,output,2010)