Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7211 Accepted Submission(s): 1858
 
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6


       
       
       
       
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
求所给数n的n次幂的末位;
快速幂;
#include <iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
void solve(int n)
{
    long long ans=1;
    int m=n;
    while(n)
    {
        if(n&1)
        ans=(ans%10*(m%10))%10;
        m=(m%10*(m%10))%10;
        n>>=1;
    }
    cout<<ans<<endl;
}
int main()
{
     int t,n;
     while(cin>>t)
     {
         while(t--)
         {
             cin>>n;
             solve(n);
         }
     }
    return 0;
}

你可能感兴趣的:(Rightmost Digit)