1059. Prime Factors

1059. Prime Factors (25)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HE, Qinming

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1^k1 * p2^k2 *…*pm^km.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1 * p2^k2 *…*pm^km, where pi's are prime factors of N in increasing order, and the exponent ki is the number of pi -- hence when there is only one pi, ki is 1 and must NOT be printed out.

Sample Input:
97532468
Sample Output:
97532468=2^2*11*17*101*1291
#include<stdio.h>
using namespace std;

bool flag[100002];
int prime[100002];

int primesize;

void init()
{
	primesize = 0;
	for(int i = 2; i <= 100000; i ++)
	{
		if(flag[i])
			continue;
		prime[primesize ++] = i;
		
		if(i >= 1000)
			continue;
		for(int j = i*i; j <= 100000; j += i)
			flag[j] = true;
	}
}

int main()
{
	init();
	int n, m;
	scanf("%d", &n);
	
	m = n;
	if(m == 1)
	{
		printf("1=1\n");
		return 0;
	}
	
	int ansPrime[30], ansNum[30];
	int ansSize = 0;
	
	for(int i = 0; i < primesize; i ++)
	{
		if(m % prime[i] == 0)
		{
			ansPrime[ansSize] = prime[i];
			ansNum[ansSize] = 0;
			while(m % prime[i] == 0)
			{
				ansNum[ansSize] ++;
				m /= prime[i];
			}
			ansSize ++;
			if(m == 1)
				break;
		}
	}
	
	if(m != 1)
	{
		ansPrime[ansSize] = m;
		ansNum[ansSize] = 1;
	}
	printf("%d=", n);
	for(int i = 0; i < ansSize; i ++)
	{
		if(i == ansSize-1)
		{
			if(ansNum[i] == 1)
				printf("%d\n", ansPrime[i]);
			else
				printf("%d^%d\n", ansPrime[i], ansNum[i]);
		}
		else
		{
			if(ansNum[i] == 1)
				printf("%d*", ansPrime[i]);
			else
				printf("%d^%d*", ansPrime[i], ansNum[i]);
		}
	}
	return 0;
}


你可能感兴趣的:(1059. Prime Factors)