Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10072 Accepted: 7191
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
Source
Stanford Local 2006
做的第一道矩阵,先从别人那里盗个模板。。
矩阵快速幂用来计算矩阵的n次方的。将时间复杂度降到log(n),原理和快速幂类似,二分的思想(想不到当年学的线性代数用到了,orz);主要在于构造矩阵;
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <ctype.h>
#include <time.h>
#include <queue>
using namespace std;
const int MOD = 10000;
struct node
{
int m[2][2];
}ans,base;
int n;
node multi(node a,node b)
{
node tmp;
for(int i=0;i<2;i++)
for(int j=0;j<2;j++)
{
tmp.m[i][j] = 0;
for(int k=0;k<2;k++)
{
tmp.m[i][j] +=(a.m[i][k] * b.m[k][j]);
tmp.m[i][j] %= MOD;
}
}
return tmp;
}
int fast_mod(int n)// 求矩阵 base 的 n 次幂
{
base.m[0][0] = base.m[0][1] = base.m[1][0] = 1;
base.m[1][1] = 0;
ans.m[0][0] = ans.m[1][1] = 1;// ans 初始化为单位矩阵
ans.m[0][1] = ans.m[1][0] = 0;
while (n)
{
if (n&1) //实现 ans *= t; 其中要先把 ans赋值给 tmp,然后用 ans = tmp * t
ans = multi(ans,base);
base = multi(base,base);
n>>=1;
}
return ans.m[0][1];
}
int main()
{
while (scanf("%d",&n)!=EOF)
{
if (n == -1)
break;
int ans = fast_mod(n);
printf("%d\n",ans);
}
return 0;
}