poj1679次小生成树

A - The Unique MST
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 1679

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3

Not Unique!

问最小生成树是否唯一,如果唯一,输出最小生成树,否者输出NotUnique!

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
const int maxn=110;
const int inf=0x3f3f3f3f;
int V,E;
int cost[105][105];
bool vis[maxn];
int pre[maxn],lowc[maxn];
int Max[maxn][maxn];///最小生成树从i到j的路径最大边权
bool used[maxn][maxn];
int prime(int n)
{
    int ans=0;

    memset(vis,false,sizeof(vis));
    memset(Max,0,sizeof(Max));
    memset(used,false,sizeof(used));
    vis[0]=true;
    pre[0]=-1;
    for(int i=1; i<n; i++)
    {
        lowc[i]=cost[0][i];
        pre[i]=0;
    }
    lowc[0]=0;
    for(int i=1; i<n; i++)
    {
        int minc=inf;
        int p=-1;
        for(int j=0; j<n; j++)
        {
            if(!vis[j]&&minc>lowc[j])
            {
                minc=lowc[j];
                p=j;
            }
        }
        if(minc==inf)
            return -1;
        ans+=minc;
        vis[p]=true;
        used[p][pre[p]]=used[pre[p]][p]=true;
        for(int j=0; j<n; j++)
        {
            if(vis[j])
                Max[j][p]=Max[p][j]=max(Max[j][pre[p]],lowc[p]);
            if(!vis[j]&&lowc[j]>cost[p][j])
            {
                lowc[j]=cost[p][j];
                pre[j]=p;
            }
        }
    }
    return ans;
}
int smst(int n,int ans)
{
    int Min=inf;
    for(int i=0; i<n; i++)
        for(int j=i+1; j<n; j++)
            if(cost[i][j]!=inf&&!used[i][j])
                Min=min(Min,ans+cost[i][j]-Max[i][j]);
    if(Min==inf)
        return -1;
    return Min;
}
int main()
{

    int t;
    cin>>t;
    int u,v,cos;
    while(t--)
    {
        scanf("%d%d",&V,&E);
        for(int i=0;i<=V;i++)
            for(int j=0;j<=V;j++)
            cost[i][j]=inf;
        for(int i=0; i<E; i++)
        {
            scanf("%d%d%d",&u,&v,&cos);
            u--;
            v--;
            cost[v][u]=cos;
            cost[u][v]=cos;
        }
        int ans=prime(V);
        int ans2=smst(V,ans);
        
        if(ans==ans2)
        {
            cout<<"Not Unique!"<<endl;
        }
        else
            cout<<ans<<endl;
    }
    return 0;
}


你可能感兴趣的:(poj1679次小生成树)