poj3723最小生成树

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9705   Accepted: 3451

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071

54223

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e5+10;
struct edge
{
    int u,v,cost;
}es[maxn];
bool cmp(edge e1,edge e2)
{
    return e1.cost<e2.cost;
}
int par[maxn],rank[maxn];
void init(int n)
{
    for(int i=0; i<=n; i++)
    {
        rank[i]=0;
        par[i]=i;
    }
}
int find(int i)
{
    if(i==par[i])
        return i;
    return par[i]=find(par[i]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
        return ;
    if(rank[x]<rank[y])
        par[x]=y;
    else
    {
        par[y]=x;
        if(rank[x]==rank[y])
            rank[x]++;
    }
}
bool same(int x,int y)
{
    return find(x)==find(y);
}
int V,E,R;
int t,N,M;

int kruskal()
{
    sort(es,es+E,cmp);
    init(V);
    int res=0;
    for(int i=0; i<E; i++)
    {
        edge e=es[i];
        if(!same(e.u,e.v))
        {
            unite(e.u,e.v);
            res+=e.cost;
        }
    }
    return res;
}
int main()
{

    cin>>t;
    while(t--)
    {
        ///cin>>N>>M>>R;
        scanf("%d%d%d",&N,&M,&R);
        V=N+M;
        E=R;
        int u,v,cost;
        for(int i=0;i<R;i++)
        {
            scanf("%d%d%d",&u,&v,&cost);
           /// cin>>u>>v>>cost;
            es[i].u=u;
            es[i].v=v+N;
            es[i].cost=-cost;
        }
        cout<<kruskal()+10000*(N+M)<<endl;
    }
    return 0;
}


你可能感兴趣的:(poj3723最小生成树)