Friend 1719 (数学+技巧+规律)

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2200    Accepted Submission(s): 1103


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
   
   
   
   
3 13121 12131
 

Sample Output
   
   
   
   
YES! YES! NO!
//看了半天没看懂,最后看了一下题解才知道规律
//a=1;b=2;
//=a*b+a+b=(a+1)(b+1)-1   === >>c+1=(a+1)(b+1);
//所以输入的数+1,只要是2或者3的倍数就是了 
#include<stdio.h>
#include<string.h>
#include<math.h>
int main(){
	int n,m,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		if(n<1)
			printf("NO!\n");
		else
		{
			n=n+1;
			while(n%2==0)
				n/=2;
			while(n%3==0)
				n/=3;
			if(n==1)
				printf("YES!\n");
			else
				printf("NO!\n");
		}
	}
	return 0;
}


 

你可能感兴趣的:(Friend 1719 (数学+技巧+规律))