http://acm.hdu.edu.cn/showproblem.php?pid=2602
Bone Collector
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
简单的01背包
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>
using namespace std;
#define N 1060
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))
typedef long long LL;
int dp[N];
int main ()
{
int t, n, V;
scanf ("%d", &t);
while (t--)
{
int vl[N], vo[N];
scanf ("%d %d", &n, &V);
for (int i=1; i<=n; i++)
scanf ("%d", &vl[i]);
for (int i=1; i<=n; i++)
scanf ("%d", &vo[i]);
met (dp, 0);
for (int i=1; i<=n; i++)
for (int j=V; j>=vo[i]; j--)
dp[j] = max (dp[j], dp[j-vo[i]]+vl[i]);
printf ("%d\n", dp[V]);
}
return 0;
}