hdu 2844 Coins(背包)

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7376    Accepted Submission(s): 3001


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
   
   
   
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
   
   
   
   
8 4

背包问题,转化为二进制,例如10个1,可转化为1,2,4,3,则10个1可以表示的所有数字,1,2,4,3都可以表示。

代码:
//531ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100000+1000;
int a[maxn];
int c[maxn];
int v[maxn];
int can[maxn];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n+m==0)
        break;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&c[i]);
        }
        memset(can,0,sizeof(can));
        can[0]=1;
        int t=0;
        int ans=0;
        for(int i=1;i<=n;i++)//转化为二进制
        {
            for(int k=0;(1<<k)<=c[i];k++)
            {
                c[i]-=(1<<k);
                v[t++]=a[i]*(1<<k);
            }
            v[t++]=a[i]*c[i];
        }
        for(int i=0;i<t;i++)
        {
            for(int k=m;k>=v[i];k--)
            {
                if((!can[k])&&can[k-v[i]])
                {
                    ans++;
                    can[k]=1;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(Algorithm)