hdu 4961 Boring Sum(2014 Multi-University Training Contest 9)

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 20    Accepted Submission(s): 12


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a 1, a 2, …, a n, let S(i) = {j|1<=j<i, and a j is a multiple of a i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a f(i). Similarly, let T(i) = {j|i<j<=n, and a j is a multiple of a i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c i as a g(i). The boring sum of this sequence is defined as b 1 * c 1 + b 2 * c 2 + … + b n * c n.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a 1, a 2, …, a n (1<= a i<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
   
   
   
   
5 1 4 2 3 9 0
 

Sample Output
   
   
   
   
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100000+1000;
int si[maxn];
int st[maxn];
int a[maxn];
int hash[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
       long long ans=0;
       memset(si,0,sizeof(si));
       memset(st,0,sizeof(st));
       memset(hash,0,sizeof(hash));
       for(int i=1;i<=n;i++)
       scanf("%d",&a[i]);
       hash[a[1]]=1;
       //printf("jdjf\n");
          for(int i=2;i<=n;i++)
          {
          // hash[a[i]]=i;
           int temp=a[i];
           for(int j=1;j*j<=temp;j++)
           {
               if(hash[j]&&temp%j==0)
               {
                   st[hash[j]]=a[i];
                   hash[j]=0;
               }
               if(hash[temp/j]&&temp%j==0)
               {
                   st[hash[temp/j]]=a[i];
                   hash[temp/j]=0;
               }
           }
           hash[a[i]]=i;
          }
           memset(hash,0,sizeof(hash));
           hash[a[n]]=n;
           for(int i=n-1;i>=1;i--)
           {
               //hash[a[i]]=i;
           int temp=a[i];
           for(int j=1;j*j<=temp;j++)
           {
               if(hash[j]&&temp%j==0)
               {
                   si[hash[j]]=a[i];
                   hash[j]=0;
               }
               if(hash[temp/j]&&temp%j==0)
               {
                   si[hash[temp/j]]=a[i];
                   hash[temp/j]=0;
               }
           }
           hash[a[i]]=i;
           }
           //printf("%d\n",n);
           for(int i=1;i<=n;i++)
           {
               //printf("%d %d\n",si[i],st[i]);
               if(si[i]==0)
               si[i]=a[i];
               if(st[i]==0)
               st[i]=a[i];
              // printf("%d %d\n",si[i],st[i]);
               ans+=(long long)si[i]*st[i];
           }
           printf("%I64d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(Algorithm)