LightOJ 1370-Bi-shoe and Phi-shoe(欧拉函数)

A - Bi-shoe and Phi-shoe
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu

Description
Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

题目大意:
首先你要明白一个数的价值的定义。给你一个数n,假设小于它的数有x个与它互质,我们称它的价值是x。
给你一个价值,让你找对应的一个数,这个数的价值大于等于题目所给的价值,且必须最小,题目一共给你n个价值,你要找n个数,并加和就好了。
最朴素的做法是根据定义找每个数的价值,然后打成一张表,然后一个个去比对,但是那样会超时。
所以可以用欧拉函数,它将直接为你打印一张每个数的价值表,当我们知道一个数x的价值时,直接从表中的x位置去搜寻,直到找到一个位置,那个位置的值大于即可。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int euler[1200000];
void getEuler();
int main()
{
    //freopen("in.txt","r",stdin);
    getEuler();
    euler[1]=0;
    int n;
    scanf("%d",&n);
    long long int sum=0;
    for(int w=1; w<=n; w++)
    {
        int b;
        scanf("%d",&b);
        sum=0;
        for(int i=1; i<=b; i++)
        {
            int q;
            scanf("%d",&q);
            int j=q-2;
            if(j<=0) j=1;
            for(;j<=1100000;j++)
            {
                //cout<<j<<" "<<euler[j]<<endl;
                if(euler[j]>=q)
                {
                    sum+=j;
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",w,sum);
    }
    return 0;
}
void getEuler()
{
    memset(euler,0,sizeof(euler));
    euler[1]=1;
    for(int i=2; i<=1100000; i++)
        if(!euler[i])
            for(int j=i; j<=1100000; j+=i)
            {
                if(!euler[j])
                    euler[j]=j;
                euler[j]=euler[j]/i*(i-1);
            }
}

你可能感兴趣的:(数论,ACM)