Background
Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.
In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will “program” a robotic arm to respond to a limited set of commands.
The Problem
The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0≤i<n−1 as shown in the diagram below:
Figure: Initial Blocks World
The valid commands for the robot arm that manipulates blocks are:
move a onto b
where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.
move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.
pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.
pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.
quit
terminates manipulations in the block world.
Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.
The Input
The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 < n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.
You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.
The Output
The output should consist of the final state of the blocks world. Each original block position numbered i ( 0≤i<n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don’t put any trailing spaces on a line.
There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).
Sample Input
10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit
Sample Output
0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:
从左到右有n个木块,编号为0~n-1,要求模拟以下4种操作(下面的a和b都是木块编号)。
move a onto b:把a和b上方的木块全部归位,然后把a摞在b上面。
move a over b:把a上方的木块全部归位,然后把a放在b所在木块堆的顶部。
pile a onto b:把b上方的木块全部归位,然后把a及上面的木块整体摞在b上面。
pile a over b:把a及上面的木块整体摞在b所在木块堆的顶部。
遇到quit时终止一组数据。a和b在同一堆的指令是非法指令,应当忽略。
#include <cstdio>
#include <string>
#include <vector>
#include <iostream>
using namespace std;
const int maxNum = 30;
// 堆数
int n;
// 每一堆都是一个vector容器
vector<int> pile[maxNum];
// 找到木块a所在的堆及其高
void find_block(int a, int &p, int &h) {
for(p = 0; p < n; p++) {
for(h = 0; h < pile[p].size(); h++) {
// vector容器通过可以通过数组形式
// 找到第几个元素
if(pile[p][h] == a) {
return;
}
}
}
}
// 把第p堆高度为h的木块上方所有木块移回原位
void clear_above(int p, int h) {
for(int i = h + 1; i < pile[p].size(); i++) {
int b = pile[p][i];
// 放回原位
pile[b].push_back(b);
}
// pile只保留下标0~h的元素
pile[p].resize(h + 1);
}
// 把第p堆高度为h及其上方的木块整体移动到p2堆的顶部
void pile_onto(int p, int h, int p2) {
for(int i = h; i < pile[p].size(); i++) {
pile[p2].push_back(pile[p][i]);
}
// pile只保留下标0~h-1的元素
pile[p].resize(h);
}
void printInfo() {
for(int i = 0; i < n; i++) {
printf("%d:", i);
for(int j = 0; j < pile[i].size(); j++) {
printf(" %d", pile[i][j]);
}
printf("\n");
}
}
int main() {
// a->b
int a, b;
cin >> n;
// 指令1,指令2
string s1, s2;
// 初始化容器
for(int i = 0; i < n; i++) {
pile[i].push_back(i);
}
while(cin >> s1 >> a >> s2 >> b) {
if(s1 == "quit") {
break;
}
// 木块所在的堆及其高度
int pa, ha;
int pb, hb;
find_block(a, pa, ha);
find_block(b, pb, hb);
// 非法指令
if(pa == pb) {
continue;
}
if(s2 == "onto") {
clear_above(pb, hb);
}
if(s1 == "move") {
clear_above(pa, ha);
}
pile_onto(pa, ha, pb);
}
printInfo();
return 0;
}