ZOJ 2316 Matrix Multiplication

Description

Let us consider undirected graph G = which has N vertices and M edges. Incidence matrix of this graph is N * M matrix A = {a ij}, such that a ij is 1 if i-th vertex is one of the ends of j-th edge and 0 in the other case. Your task is to find the sum of all elements of the matrix A TA.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

The first line of the input file contains two integer numbers - N and M (2 <= N <= 10 000, 1 <= M <= 100 000). 2M integer numbers follow, forming M pairs, each pair describes one edge of the graph. All edges are different and there are no loops (i.e. edge ends are distinct).


Output

Output the only number - the sum requested.


Sample Input

1

4 4
1 2
1 3
2 3
2 4


Sample Output

18

矩阵乘法,知道算法就简单了。

#include<stdio.h>
#include<map>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10005;
int T,a[maxn],x,y,n,m;
long long ans;

int main()
{	
	while (~scanf("%d",&T))
	{
		while (T--)
		{
			memset(a,0,sizeof(a));
			scanf("%d%d",&n,&m);
			for (int i=0;i<m;i++)
			{
				scanf("%d%d",&x,&y);
				a[x]++;
				a[y]++;
			}
			ans=0;
			for (int i=1;i<=n;i++)
				ans+=(long long)(a[i])*a[i];
			cout<<ans<<endl;
			if (T) printf("\n");
		}
	}
	return 0;
}


你可能感兴趣的:(ZOJ,矩阵乘法)