杭电ACM 1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 306310    Accepted Submission(s): 59185


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
   
   
Case 1: 1 + 2 = 3 Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

#include<iostream>
#define MAX 1000
using namespace std;

int main(){
    int A[MAX],B[MAX];
    char a[MAX]={0},b[MAX]={0};
    int T,cont=1;;
    cin>>T;
    while(T--){
        cin>>a>>b;
        int alen=strlen(a);
        int blen=strlen(b);
        int c=0;//代表进位
        int sum;//代表和
        int i,j;

        for(i=0;i<MAX;i++){
            A[i]=0;
            B[i]=0;
        }
        for(i=0;i<alen;i++){
            A[i]=a[alen-1-i]-'0';
        }
        for(j=0;j<blen;j++){
            B[j]=b[blen-1-j]-'0';
        }

        cout<<"Case "<<cont++<<":"<<endl;
        for(i=alen-1;i>=0;i--)
            cout<<A[i];
        cout<<" + ";
        for(j=blen-1;j>=0;j--){
            cout<<B[j];
        }
        cout<<" = ";
        int count=alen-blen>0?alen:blen;
    
        for(int k=0;k<count;k++){
            sum=A[k]+B[k]+c;
            c=sum/10;///求进位
            A[k]=sum%10;//求低位
        }

        A[count]=c;///最高位为进位
        count= c==1?count:count-1;
    
        for(int n=count;n>=0;n--){
             cout<<A[n];
        }
                  cout<<endl;
        if(0!=T)
            cout<<endl;
    }
    

    return 0;
}


你可能感兴趣的:(ACM,杭电)