二维凸包

二维凸包模板

p[1010]//输入的点集,res[1010]//输出的点集
int n;//点的个数
int cmp(Point a,Point b)//先对x坐标排序,在比较y坐标
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int ConvexHull()//返回凸包顶点数
{
    sort(p,p+n,cmp);
    int m=0;
    for(int i=0;i<=n-1;i++)
    {
        while(m>1&&Cross(res[m-1]-res[m-2],p[i]-res[m-2])<=0)
            m--;
        res[m++]=p[i];
    }
    int k=m;
    for(int i=n-2;i>=0;i--)
    {
        while(m>k&&Cross(res[m-1]-res[m-2],p[i]-res[m-2])<=0)
            m--;
        res[m++]=p[i];
    }
    if(n>1)//起始点重复
        m--;
    return m;
}
<p>注意:当图为两个点时,直接输出这两个点的长度,下式会不成立</p>
for(int i=0;i<=m-2;i++)//求凸包的长度
            sum+=length(res[i],res[i+1]);
        sum+=length(res[0],res[m-1]);


poj 1113

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<string>
#include<algorithm>
#define LL long long
#define inf 0x3f3f3f3f
using namespace std;
const double pi=atan(1.0)*4;
struct Point
{
    double x;
    double y;
}p[1010],res[1010];
int n;
typedef Point Vector;
Vector operator - (Point a,Point b) {return Vector{a.x-b.x,a.y-b.y};}
double Cross(Vector a,Vector b)//向量a,b的叉积,在二维坐标系下是一个数
{
    return a.x*b.y-a.y*b.x;
}
int cmp(Point a,Point b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int ConvexHull()//返回凸包顶点数
{
    sort(p,p+n,cmp);
    int m=0;
    for(int i=0;i<=n-1;i++)
    {
        while(m>1&&Cross(res[m-1]-res[m-2],p[i]-res[m-2])<=0)
            m--;
        res[m++]=p[i];
    }
    int k=m;
    for(int i=n-2;i>=0;i--)
    {
        while(m>k&&Cross(res[m-1]-res[m-2],p[i]-res[m-2])<=0)
            m--;
        res[m++]=p[i];
    }
    if(n>1)//起始点重复
        m--;
    return m;
}
double length(Point a,Point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main()
{
        int l;
        cin>>n>>l;
        for(int i=0;i<=n-1;i++)
            cin>>p[i].x>>p[i].y;
        int m=ConvexHull();
        double sum=0;
        for(int i=0;i<=m-2;i++)
            sum+=length(res[i],res[i+1]);
        sum+=length(res[0],res[m-1]);
        sum+=2*pi*l;
        printf("%.0lf\n",sum);
    return 0;
}



你可能感兴趣的:(凸包)