D - 胜利大逃亡 hdu1253

Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1. 


 

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫) 

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交. 
 

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1. 
 

Sample Input

        
        
        
        
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output

        
        
        
        
11
 

#include<stdio.h>
#include<queue>
#include<cstring>
using namespace std;
int visit[55][55][55];
int map[55][55][55];
int dir[6][3]={{0,0,1},{0,1,0},{1,0,0},{0,0,-1},{0,-1,0},{-1,0,0}};
struct node{
int x,y,z,s;};
int a,b,c;
int abs(int w)
{
    return w<0?-w:w;
}
int check(int x,int y,int z)
{
    if(x>=0&&y>=0&&x<a&&y<b&&z>=0&&z<c&&map[x][y][z]==0)
        return 1;
    return 0;
}
int bfs(int m)
{
    queue<node>q;
    node t,next;
    t.x=0;
    t.y=0;
    t.z=0;
    t.s=0;
    q.push(t);
    map[t.x][t.y][t.z]=1;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t.s>m)
            return -1;
        if(t.x==a-1&&t.y==b-1&&t.z==c-1&&t.s<=m)
            return t.s;
        for(int i=0;i<6;i++)
        {
            next.x=t.x+dir[i][0];
            next.y=t.y+dir[i][1];
            next.z=t.z+dir[i][2];
            if(check(next.x,next.y,next.z)&&!visit[next.x][next.y][next.z])
            {
                visit[next.x][next.y][next.z]=1;
                next.s=t.s+1;
                if(abs(next.x-a+1)+abs(next.y-b+1)+abs(next.z-c+1)+next.s>m)
                    continue;
                q.push(next);
            }
        }
    }

    return -1;
}
int main()
{
    int n,m;
    scanf("%d",&n);
    while(n--)
    {
        memset(map,0,sizeof(map));
        memset(visit,0,sizeof(visit));
        scanf("%d%d%d%d",&a,&b,&c,&m);
        for(int i=0;i<a;i++)
            for(int j=0;j<b;j++)
            for(int k=0;k<c;k++)
            scanf("%d",&map[i][j][k]);
            int z=bfs(m);
        printf("%d\n",z);
    }
}


你可能感兴趣的:(D - 胜利大逃亡 hdu1253)