1583 - Digit Generator

Digit Generator

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1 N 100, 000 .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

如果x加上x的各个数字之和得到y,就说x是y的生成元。给出n(1≤n≤100000),求最小生成元。无解输出0。例如,n=216,121,2005时的解分别为198,0,1979。

#include <stdio.h>
#include <string.h>
#define num 100005
int digitSum[num];

int main() {
    memset(digitSum, 0, sizeof(digitSum));
    int T,N;
    // 一次直接缓存所有生成元
    for(int i = 1; i < num; i++) {
        int x = i, y = i;
        while(y != 0) {
            x += y % 10;
            y /= 10;
        }
        // 取最小生成元,没有生成元则为0
        if(digitSum[x] == 0 || digitSum[x] > i) {
            digitSum[x] = i;
        }
    }
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &N);
        printf("%d\n", digitSum[N]);
    }
    return 0;
}

你可能感兴趣的:(ACM,uva,Uva-1583)