HDU 1061 Rightmost Digit(快速幂题目)

Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

本题算得上是一道纯快速幂的题目,一开始想求循环节来着,,无奈没找到。
下面先附上快速幂算法的代码:

__int64 PowerMod(__int64 a, __int64 b)
{
    __int64 ans = 1;
    a = a % 10;
    while(b>0)
    {
        if(b % 2 == 1)
            ans = (ans * a) % 10;
        b = b/2;
        a = (a * a) % 10;
    }
    return ans;
}

下面是本题的完整AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

__int64 PowerMod(__int64 a, __int64 b)
{
    __int64 ans = 1;
    a = a % 10;
    while(b>0)
    {
        if(b % 2 == 1)
            ans = (ans * a) % 10;
        b = b/2;
        a = (a * a) % 10;
    }
    return ans;
}

int main()
{
    int n,t;
    scanf("%d",&t);
    int a[20]= {1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
    while(t--)
    {
        scanf("%d",&n);
        long long int sum=PowerMod(n,n);
        printf("%lld\n",sum);
    }
    return 0;
}

你可能感兴趣的:(快速幂)