HDU 1217 Arbitrage

 

题目大意就是给了你各种货币之间的兑换关系,问你是否存在1个单元的某货币经过一个回路的兑换后>=1个单元( 有利润 )

 

                                       Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2864    Accepted Submission(s): 1284


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 


 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 


 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 


 

Sample Input
   
   
   
   
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 


 

Sample Output
   
   
   
   
Case 1: Yes Case 2: No

 

 

其实只要用Floyd算法,稍微修改一下求最短路的公式就好,然后查看是否存在mp[i][i] > 1

#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int M = 50;
double mp[M][M],dis[M];
int n,m;
char money[M][M];
char start[M],end[M];
bool visit[M];
int find( char s[] )
{
    for( int i=1 ; i<=n ; i++ ){
         if( !strcmp( money[i] , s ) )     
             return i;
    }    
}

int Floyd(  )
{
    for( int k=1 ; k<=n ; k++ )
         for( int i=1 ; i<=n ; i++ )
              for( int j=1 ; j<=n ; j++ ){
                   if( mp[i][j] < mp[i][k] * mp[k][j] )
                       mp[i][j] = mp[i][k] * mp[k][j];   
              }
    for( int i=1 ; i<=n ; i++ )
         if( mp[i][i] > 1 )
             return 1;
    return 0;
}

int main()
{
    int cas =1;
    while( scanf("%d",&n) && n ){
           for( int i=1 ; i<=n ; i++ ){
                for( int j=1 ; j<=n ; j++ )
                         mp[i][j] = 0;
           }
           
           for( int i=1 ; i<=n ; i++ ){
                scanf("%s",&money[i]);     
           }
           scanf("%d",&m);
           int x,y;
           double rate;
           for( int i=1 ; i<=m ; i++ ){
                scanf("%s",start);
                scanf("%lf",&rate);
                scanf("%s",end);
                x = find( start );
                y = find( end );
                mp[x][y] = rate;
           }
           if( Floyd() )
               printf("Case %d: Yes\n",cas++);
           else
               printf("Case %d: No\n",cas++);
    }
    return 0;
}


 

你可能感兴趣的:(HDU 1217 Arbitrage)