Coins (HDU_2844) 二进制优化+多重背包

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11117    Accepted Submission(s): 4461


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
   
   
   
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
   
   
   
   
8 4
 

Source
2009 Multi-University Training Contest 3 - Host by WHU


解题思路:给出一些硬币的价值和数量,求这些硬币能组成1-m中的哪些值。

解题思路:二进制思想完全背包。需要将各种硬币逐一判断,以确定是将将多重背包转化成完全背包还是用二进制转化为01背包’事实证明代码写得挫不挫差别非常大。。。代码仿自大神http://blog.csdn.net/libin56842/article/details/9396649

代码如下:

#include"cstdio"
#include"cstring"
#define INF 110000000
using namespace std;
const int maxn=105;
int dp[100005];
int A[maxn],C[maxn];
int m;
int max(int x,int y){
	return x>y?x:y;
}
void ZeroOnePack(int cost,int wei){
	for(int i=m;i>=cost;i--){
		dp[i]=max(dp[i],dp[i-cost]+wei);
	}
}
void CompeletePack(int cost,int wei){
	for(int i=cost;i<=m;i++){
		dp[i]=max(dp[i],dp[i-cost]+wei);
	}
}
void MultiplePack(int cost,int wei,int cnt){
	if(m<=cost*cnt){
		CompeletePack(cost,wei);
	}
	else{
		int k=1;
		while(k<=cnt){
			ZeroOnePack(k*cost,k*wei);
			cnt=cnt-k;
			k*=2;
		}
		ZeroOnePack(cnt*cost,cnt*wei);
	}
}
int main(){
	int n;
	while(1){
		scanf("%d%d",&n,&m);
		if(n==0&&m==0) break;
		for(int i=1;i<=n;i++){
			scanf("%d",&A[i]);
		}	
		for(int i=1;i<=n;i++){
			scanf("%d",&C[i]);
		}
		for(int i=1;i<=m;i++){
			dp[i]=-INF;
		}
		dp[0]=0;
		for(int i=1;i<=n;i++){
			MultiplePack(A[i],A[i],C[i]);
		}
		int ans=0;
		for(int i=1;i<=m;i++){
			if(dp[i]>0){
				ans++;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


 

你可能感兴趣的:(01背包,多重背包,二进制优化)