ZOJ3471 状态压缩DP

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3471

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22


/**
zoj 3471 状态压缩dp
有n块石头两碰撞,后者消失并释放一定的能量,问怎样安排碰撞能使整个过程完成后释放的能量最多。
解题思路:用一个n位的二进制数表示所有的状态。各位为1则有石头,为0表示没有石头,从dp[(1<<n)-1]倒推,
最后合并成只有一个石头的状态取最大即为答案。
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

int dp[1<<10+10];
int a[12][12];
int n;

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
              scanf("%d",&a[i][j]);
        for(int i=(1<<n)-1;i>=0;i--)
            for(int j=0;j<n;j++)
            {
                 if(i&(1<<j))
                 {
                     for(int k=0;k<n;k++)
                     {
                         if(k==j)continue;
                         if(i&(1<<k))continue;
                         dp[i]=max(dp[i],dp[i|(1<<k)]+a[j][k]);
                     }
                 }
            }
        int ans=-1;
        for(int i=0;i<10;i++)
        {
            ans=max(dp[1<<i],ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(ZOJ3471 状态压缩DP)