HDOJ 5523 Game

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 748    Accepted Submission(s): 275


Problem Description
XY is playing a game:there are N pillar in a row,which numbered from 1 to n.Each pillar has a jewel.Now XY is standing on the S-th pillar and the exit is in the T-th pillar.XY can leave from the exit only after they get all the jewels.Each time XY can move to adjacent pillar,or he can jump to boundary ( the first pillar or the N-th pillar) by using his superpower.However,he needs to follow a rule:if he left the pillar,he no can not get here anymore.In order to save his power,XY wants to use the minimum number of superpower to pass the game.
 

Input
There are multiple test cases, no more than 1000 cases.
For each case,the line contains three integers:N,S and T. (1N10000,1S,TN)
 

Output
The output of each case will be a single integer on a line: the minimum number of using superpower or output -1 if he can't leave.
 

Sample Input
   
   
   
   
4 1 4 4 1 3
 

Sample Output
   
   
   
   
0 1 题意:n个柱子,s为起点,t为目标,求s到t的最小耗能 思路:如果不止1个柱子而且s和t相同则无解。其他情况下如果s和t分别在两边则是0,如果s在一头或s在中间但是s和t相邻则只需要1,其他情况下 为2。刚开始以为s和t相同时为0。。。醉。。。 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100100
#define MOD 1000000007
#define LL long long
#define INF 0xfffffff
using namespace std;
int main()
{
	int n,s,t;
	while(scanf("%d%d%d",&n,&s,&t)!=EOF)
	{
		if(n>1&&s==t)
		{
			printf("-1\n");
			continue;
		}
		else if((s==1&&t==n)||(s==n&&t==1))
		{
			printf("0\n");
			continue;
		}
		else if((s==1&&t!=n)||(t!=1&&s==n)||(s!=1&&s+1==t)||(s!=n&t+1==s))
		{
			printf("1\n");
			continue;
		}
		else
		printf("2\n");
	}
    return 0;
}


你可能感兴趣的:(HDOJ 5523 Game)