Hdu1757



A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3933    Accepted Submission(s): 2380


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
   
   
   
   
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
   
   
   
   
45 104
 

Author
linle
裸矩阵快速幂,递推式已经给出来了,构造出矩阵,模板就好了,(PS:有没有好点的快速幂模板,求!!!!!!!)
代码:
#include<stdio.h>
#include<string.h>
typedef struct haha
{
    int mar[10][10];
}marty;
marty a;
int n,m;
marty multi(struct haha a1,struct haha a2)
{
    marty temp;
    int i,j,k;
    for(i=0;i<10;i++)
        for(j=0;j<10;j++)
        {
            temp.mar[i][j]=0;
            for(k=0;k<10;k++)
            {
                temp.mar[i][j]+=(a1.mar[i][k]*a2.mar[k][j])%m;
            }
            temp.mar[i][j]%=m;
        }
        return temp;
}
marty  matrix_binary(int k)//二分思想也可以用二进制方法解决
{
    marty b;
    memset(b.mar,0,sizeof(b.mar));
    for(int i=0;i<10;i++)
        b.mar[i][i]=1;
    while(k)
    {
        if(k & 1) 
            b = multi(b,a);
        a = multi(a,a);
        k = k >> 1;
    }
    return b;
}
int main()
{
          int i,j,ans;
          while(scanf("%d %d",&n,&m)!=EOF)
          {
            memset(a.mar,0,sizeof(a.mar));
            for(i = 1;i < 10;i++)
                 a.mar[i][i-1] = 1;
                 for(j=0;j<10;j++)
                     scanf("%d",&a.mar[0][j]);
                 if(n<10) {printf("%d\n",n);continue;}
              n=n-9;
            marty c=matrix_binary(n);
              ans=0;
                for(i = 0;i < 10;i++)
                    ans += (c.mar[0][i] * (9-i)) % m;
                    printf("%d\n",ans%m);
          }
          return 0;
}

你可能感兴趣的:(Hdu1757)