poj 2955 Brackets

题目:

Description
We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input
The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output
For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end
Sample Output
6
6
4
0
6

思路:

题意:给你一串()[]括号,要你求出这串括号的最大匹配个数,如’(‘与’)’匹配,为2个,’[‘与’]’匹配,为2个,其他不能匹配…….
区间dp
dp[i][j]表示从第i个到第j个区间内的最大匹配个数。
如果i,j位置上对应的字符括号匹配那么dp[i][j]=dp[i+1][j-1]+2。

对于i~j区间,我们可以把它不断划分成更小的区间直至一个元素组成的区间,枚举它们的组合,求合并的最优解。
i<=k<=j
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);

代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
int dp[105][105];
char str[105];
int main()
{
    while (scanf("%s",str) && str[0]!='e'){
        memset(dp,0,sizeof(dp));
        int n = strlen(str);
        int j;
        for (int len = 1; len < n; len++){
            for (int i = 0; i + len < n; i++){
                j = i + len;
                if ((str[i] == '('&& str[j] == ')') || (str[i] == '['&& str[j] == ']')){
                    dp[i][j] = dp[i + 1][j - 1] + 2;
                }
                for (int k = i; k <= j; k++){
                    dp[i][j] = max(dp[i][j],dp[i][k]+dp[k][j]);
                }
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
    return 0;
}

你可能感兴趣的:(区间DP)