表达式求值

表达式求值

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述
ACM队的mdd想做一个计算器,但是,他要做的不仅仅是一计算一个A+B的计算器,他想实现随便输入一个表达式都能求出它的值的计算器,现在请你帮助他来实现这个计算器吧。
比如输入:“1+2/4=”,程序就输出1.50(结果保留两位小数)
输入
第一行输入一个整数n,共有n组测试数据(n<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个运算式,每个运算式都是以“=”结束。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数。
数据保证除数不会为0
输出
每组都输出该组运算式的运算结果,输出结果保留两位小数。
样例输入
2
1.000+2/4=
((1+2)*5+1)/4=
样例输出
1.50
4.00

思路:回来复习下表达式求值, 中缀式转换为逆波兰式求值。(附个表达式求值模板)

 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <stack>

using namespace std;

char str[1001];
stack<double> num;
stack<char> op;

int measure(char c)
{
    switch(c)
	{
	case '=':                       //定义字符优先级
		return 1;
	case '+':
		return 2;
	case '-':
		return 2;
	case '*':
		return 3;
	case '/':
		return 3;
	case '(':
		return 0;
	case ')':
		return 0;
	}
}

double calc(double a, double b, char c)     //计算
{
	switch(c)
	{
	case '+':
		return a + b;
	case '-':
		return a - b;
	case '*':
		return a * b;
	case '/':
		return a / b;
	}
}

int main()
{
	int n;
	scanf("%d", &n);
    int len, length;
	double temp, a, b;
	char c; 
	while(n--)
	{
	    memset(str, 0, sizeof(str));
		op.push('=');
		scanf("%s", str);
		len = strlen(str) - 1;
		for(int i = 0; i < len; i++)
		{
		    if(str[i] >= '0' && str[i] <= '9')
			{
			    sscanf(&str[i], "%lf%n", &temp, &length);          //注意sscanf的用法
				num.push(temp);
				i += length - 1;                      //后面i还要加1(for循环), 此处-1
			}
            else
			{
			    if(str[i] == '(' || measure(str[i]) > measure(op.top()))
				{
				    op.push(str[i]);
				}
				else
				{
				    if(str[i] == ')' )
					{
						while(op.top() != '(')
						{
						    c = op.top();
						    op.pop();
							b = num.top();
							num.pop();
							a = num.top();
							num.pop();
							num.push(calc(a,b,c));
						}
                        op.pop();  
					}
					else
					{
					    while(measure(str[i]) <= measure(op.top()) && op.top() != '(')
						{
						    c = op.top();
						    op.pop();
							b = num.top();
							num.pop();
							a = num.top();
							num.pop();
							num.push(calc(a,b,c));
						}
						op.push(str[i]);
					}
				}
			}
		}
		while(op.top() != '=')                 //符号栈弹空, 才算结束
		{
			c = op.top();
			op.pop();
			b = num.top();
			num.pop();
			a = num.top();
			num.pop();
			num.push(calc(a,b,c));
		}
		op.pop();
		printf("%.2lf\n", num.top());          //最后留在数栈中的即为最后结果
		num.pop();
	}

    return 0;
}
        



你可能感兴趣的:(栈)