题目链接:HDU1711
Number Sequence
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19372 Accepted Submission(s): 8328
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
题意:两个串s和t每个串元素由数字组成,问第一个串是不是包含第二个串。
题目分析:KMP模板
//
// main.cpp
// HDU1711
//
// Created by teddywang on 16/4/21.
// Copyright © 2016年 teddywang. All rights reserved.
//
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int s[1000010],t[10010],nexts[100020];
int T,m,n;
void getnext()
{
int i=0,j=-1;
nexts[0]=-1;
while(i<m)
{
if(j==-1||t[i]==t[j])
{
//nexts[++i]=++j;
if(t[++i]!=t[++j])
nexts[i]=j;
else nexts[i]=nexts[j];
}
else j=nexts[j];
}
}
int kmp()
{
int i=0,j=0;
int ans=-1;
while(i<n&&j<m)
{
if(s[i]==t[j]||j==-1)
{
if(j==m-1)
ans=i-m+2;
++i;++j;
}
else j=nexts[j];
}
return ans;
}
int main()
{
cin>>T;
while(T--)
{
cin>>n>>m;
for(int i=0;i<n;i++)
cin>>s[i];
for(int i=0;i<m;i++)
cin>>t[i];
getnext();
cout<<kmp()<<endl;
}
}