poj2488A Knight's Journey

A Knight's Journey
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30965   Accepted: 10596

Description

poj2488A Knight's Journey_第1张图片 Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

#include<iostream>

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#include<set>
//#include<map>
#include<cmath>
using namespace std;
typedef long long LL;
const int MAX=0xfffffff;
int vis[30][30];
int x[30],y[30];
int p,q;
int dirx[]={-1,1,-2,2,-2,2,-1,1};
int diry[]={-2,-2,-1,-1,1,1,2,2};
int flag;
void dfs(int a,int b,int num)
{
    x[num]=a;
    y[num]=b;
    if(num==p*q)
    {
        for(int i=1;i<=p*q;i++)
            printf("%c%d",y[i]+'A'-1,x[i]);
        printf("\n\n");
        flag=1;
        return ;
    }
    if(flag)  return ;
    for(int i=0;i<=7;i++)
    {
        int tx=a+dirx[i];
        int ty=b+diry[i];
        if(!vis[tx][ty]&&tx>0&&ty>0&&tx<=p&&ty<=q)
        {
            vis[tx][ty]=1;
            dfs(tx,ty,num+1);
            vis[tx][ty]=0;
        }
    }
}
int main( )
{
   // freopen("1.txt","r",stdin);
    int t;
    scanf("%d",&t);
    for(int kase=1;kase<=t;kase++)
    {
        scanf("%d %d",&p,&q);
        memset(vis,0,sizeof(vis));
        flag=0;
        printf("Scenario #%d:\n",kase);
        vis[1][1]=1;    //这句也可以写到dfs中
        dfs(1,1,1);
        if(!flag)  printf("impossible\n\n");
    }
    return 0;

}


以前不太会写搜索,写多了,发现深搜和广搜一样,算是有模板的

你可能感兴趣的:(搜索)