HDU - 5012 Dice(BFS)

Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)

HDU - 5012 Dice(BFS)_第1张图片
Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A.

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
   
   
   
   
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
   
   
   
   
0 3 -1 题意:求起始到终态的步骤 思路:简单的BFS+判重,注意判重数组开准点
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 6;

struct Node{
	int arr[maxn], step;
	Node() {
		memset(arr, 0, sizeof(arr));
		step = 0; 
	}
}start, end;
int vis[maxn*200000];

int cal(Node a) {
	int num = 0;
	for (int i = 0; i < maxn; i++) {
		num = num * 10 + a.arr[i]; 
	}
	return num;
}

bool equal(Node a, Node b) {
	for (int i = 0; i < maxn; i++)
		if (a.arr[i] != b.arr[i])
			return false;
	return true;
}

Node turn(Node a, int i) {
	Node c;
	if (i == 1) {
		c.arr[0] = a.arr[3];
		c.arr[1] = a.arr[2];
		c.arr[2] = a.arr[0];
		c.arr[3] = a.arr[1];
		c.arr[4] = a.arr[4];
		c.arr[5] = a.arr[5]; 
	}
	if (i == 2) {
		c.arr[0] = a.arr[2];
		c.arr[1] = a.arr[3];
		c.arr[2] = a.arr[1];
		c.arr[3] = a.arr[0]; 
		c.arr[4] = a.arr[4];
		c.arr[5] = a.arr[5]; 
	}
	if (i == 3) {
		c.arr[0] = a.arr[5];
		c.arr[1] = a.arr[4];
		c.arr[2] = a.arr[2];
		c.arr[3] = a.arr[3]; 
		c.arr[4] = a.arr[0];
		c.arr[5] = a.arr[1]; 
	}
	if (i == 4) {
		c.arr[0] = a.arr[4];
		c.arr[1] = a.arr[5];
		c.arr[2] = a.arr[2];
		c.arr[3] = a.arr[3]; 
		c.arr[4] = a.arr[1];
		c.arr[5] = a.arr[0];
	}
	return c;
}

int bfs() {
	memset(vis, 0, sizeof(vis));
	queue<Node> q;
	q.push(start);
	Node tmp; 
	vis[cal(start)] = 1;
	while (!q.empty()) {
		tmp = q.front(); 
		q.pop();            
		if (equal(tmp, end)) {
			return tmp.step;
		}
		for (int i = 1; i <= 4; i++) {
			Node c;
			c = turn(tmp, i);
			if (!vis[cal(c)]) {
				c.step = tmp.step + 1; 
				vis[cal(c)] = 1;
				q.push(c);
			} 
		}
	} 
	return -1;
}

int main() {
	while (scanf("%d", &start.arr[0]) != EOF) {
		for (int i = 1; i < maxn; i++) 
			scanf("%d", &start.arr[i]);
		for (int i = 0; i < maxn; i++) 
			scanf("%d", &end.arr[i]);

		printf("%d\n", bfs());
	}    
	return 0;
}



你可能感兴趣的:(HDU - 5012 Dice(BFS))