NYOJ 431 Dragon Balls 并查集

        路径压缩的经典应用。输入x和y后,可以找到rootx和rooty,则rankk[rootx]++,这是因为rankk[rooty]一定是等于0的,所以不需要加rankk[rooty]。接下来就需要在路径压缩中再加一次了。设fx=father[x],若fx!=x,则在找x的根节点的过程中,rankk[x]+=rankk[fx]即可,这点也是容易理解的。。题目:

Dragon Balls

时间限制: 1000 ms  |  内存限制: 1000 KB
难度: 5
描述

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

输入
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
输出
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
样例输入
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
样例输出
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
int father[10005],num[10005],rankk[10005];
int find(int x){
  int fx=father[x];
  if(fx==x){return father[x];}
  else{
	father[x]=find(father[x]);
	rankk[x]+=rankk[fx];
  }
  return father[x];
}
int main(){
	int numcase,k=0;
	scanf("%d",&numcase);
	while(numcase--){
	  int n,q;
	  scanf("%d%d",&n,&q);
	  for(int i=1;i<=n;++i)
	  {father[i]=i;num[i]=1;rankk[i]=0;}
	  char s[2];
	  int x,y;
	  printf("Case %d:\n",++k);
	  while(q--){
		  scanf("%s",s);
		  if(s[0]=='T'){
		  scanf("%d%d",&x,&y);
		  int rootx=find(x);
		  int rooty=find(y);
		  rankk[rootx]++;
		  father[rootx]=rooty;
		  num[rooty]+=num[rootx];
		}
		else{
		  scanf("%d",&x);
		  int rootx=find(x);
		  printf("%d %d %d\n",rootx,num[rootx],rankk[x]);
		}
	  }
	}
	return 0;
}        



你可能感兴趣的:(NYOJ 431 Dragon Balls 并查集)