HDU 4185 Oil Skimming(匈牙利算法)

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1822    Accepted Submission(s): 754


Problem Description
Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
 

Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.
 

Output
For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
 

Sample Input
   
   
   
   
1 6 ...... .##... .##... ....#. ....## ......
 

Sample Output
   
   
   
   
Case 1: 3
 
题意:
给你n*n的网格,#代表油,。代表海,让你一次取出一个1*2 或 2*1的油田问最多取出多少个。

思路:
可以转换成二分图的最大匹配数,用匈牙利算法。
先把油田一个一个进行编号,然后发现油田相邻的话,两两相连,匹配即可!
最后除以2.因为双向的代表1个嘛!
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 600 + 10;
vector<int>g[maxn];
int from[maxn],ans,n;
bool use[maxn];
int mp[maxn][maxn];
bool match(int x){
	int len = g[x].size();
	for (int i = 0; i < len; ++i)
	if (!use[g[x][i]]){
		use[g[x][i]] = true;
		if (from[g[x][i]] == -1 || match(from[g[x][i]])){
			from[g[x][i]] = x;
			return true;
		}
	}
	return false;
}
int hungary(){
	ans = 0;
	memset(from, 255 ,sizeof(from));
	for (int i = 1; i <= n; ++i){
		memset(use,0,sizeof(use));
		if (match(i))++ans;
	}
	return ans;
}
int main(){
	int T,cnt=0,m;
	memset(mp,0,sizeof(mp));
	scanf("%d",&T);
	while(T--){
		for (int i = 0; i < maxn; ++i)g[i].clear();
		n=0;
		scanf("%d",&m);
		for (int i = 1; i <= m; ++i){
			getchar();
			for (int j = 1; j <= m; ++j){
				if (getchar() == '#')mp[i][j] = ++n;
				else mp[i][j] = 0;
			}
		}
		for (int i = 1; i <= m; ++i){
			for (int j = 1; j <= m; ++j)if (mp[i][j]){
				int u = mp[i][j];
				if (mp[i-1][j])g[u].push_back(mp[i-1][j]);		
				if (mp[i+1][j])g[u].push_back(mp[i+1][j]);
				if (mp[i][j-1])g[u].push_back(mp[i][j-1]);
				if (mp[i][j+1])g[u].push_back(mp[i][j+1]);
			}
		}
		hungary();
		printf("Case %d: %d\n",++cnt,ans/2);
	}
	return 0;
}


你可能感兴趣的:(C语言)