A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 304766 Accepted Submission(s): 58864
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
Author
Ignatius.L
分析:
昨天晚上一道试手题,本以为自己可以轻松AC,没想到一直有错误,今天才发现犯了一个低级的错误,
用Gets()函数第二个字符串输入时第一个字符为空格,导致了结果一直不对,还是基础不够牢固格式化输入输出没有记牢
#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int c[1100],a1[1100],b1[1100];
int main()
{
int m,x1,y1,t,k=1,i,j;
scanf("%d",&m);
while(m--)
{
for(i=0; i<=1100; i++)
a1[i]=b1[i]=c[i]=0;
scanf("%s%s",a,b);
printf("Case %d:\n%s + %s = ",k++,a,b);
int x=strlen(a);
int y=strlen(b);
for(i=x-1,t=0; i>=0 ; i--,t++)
a1[t]=a[i]-'0';
for(i=y-1,t=0; i>=0; i--,t++)
b1[t]=b[i]-'0';
t=x>y?x:y;
for(i=0; i<t; i++)
{
c[i]+=a1[i]+b1[i];
if(c[i]>9)
{
c[i+1]++;
c[i]%=10;
}
}
while(c[t]!=0)
t++;
for(j=t-1; j >= 0; j --)
printf("%d",c[j]);
printf("\n");
if(m!=0)
printf("\n");
}
return 0;
}