ZOJ 3212 K-Nice

Description

This is a super simple problem. The description is simple, the solution is simple. If you believe so, just read it on. Or if you don't, just pretend that you can't see this one.

We say an element is inside a matrix if it has four neighboring elements in the matrix (Those at the corner have two and on the edge have three). An element inside a matrix is called "nice" when its value equals the sum of its four neighbors. A matrix is called "k-nice" if and only if k of the elements inside the matrix are "nice".

Now given the size of the matrix and the value of k, you are to output any one of the "k-nice" matrix of the given size. It is guaranteed that there is always a solution to every test case.

Input

The first line of the input contains an integer T (1 <= T <= 8500) followed by T test cases. Each case contains three integers nmk (2 <=nm <= 15, 0 <= k <= (n - 2) * (m - 2)) indicating the matrix size n * m and it the "nice"-degree k.

Output

For each test case, output a matrix with n lines each containing m elements separated by a space (no extra space at the end of the line). The absolute value of the elements in the matrix should not be greater than 10000.

Sample Input

2
4 5 3
5 5 3

Sample Output

2 1 3 1 1
4 8 2 6 1
1 1 9 2 9
2 2 4 4 3
0 1 2 3 0
0 4 5 6 0
0 0 0 0 0
0 0 0 0 0

0 0 0 0 0

简单的构造就好了,注意到只有四边之和等于当前数的才是nice

只构造0就好了。其余的随便填。

#include<iostream>  
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
const int maxn = 20;
int T, a[maxn][maxn], n, m, k;

int main(){
	cin >> T;
	while (T--)
	{
		cin >> n >> m >> k;		k += m - 2;	 k = -k;
		memset(a, 0, sizeof(a));
		for (int i = 2; i <= n;i++)
			for (int j = 2; j < m; j++)
				if (k < 0) k++; else a[i][j] = ++k;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j < m; j++) printf("%d ", a[i][j]);
			printf("%d\n", a[i][m]);
		}
	}
	return 0;
}


你可能感兴趣的:(ZOJ)