HDOJ 2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7567    Accepted Submission(s): 3361


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
HDOJ 2009 Summer Exercise(5)
 

Recommend
lcy
                                                                                                  给你一块h*w的木板,放进一些1*L的物品,求每次放空间能容纳且最上边的位子,做法是每次找到最大值的位子,然后减去L
用线段树的query求区间最大值的位子并进行更新。
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>


using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , m  , pos << 1
#define rson m + 1 , r , pos << 1 | 1
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 200000 + 100;
const int maxw = 10000000 + 20;
const int MAXNNODE = 1000000 +10;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 1000000007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
int node[MAXN << 2];///记录i结点子树w的最大值
int h , w , n;
void push_up(int pos)
{
    node[pos] = max(node[pos << 1] , node[pos << 1| 1]);
}
void build(int l , int r , int pos)
{
    node[pos] = w;
    if(l == r)return ;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}
int query(int x , int l , int r , int pos)
{
    if(l == r)
    {
        node[pos] -= x;
        return l;
    }
    int m = (l + r) >> 1;
    int ans = (node[pos << 1] >= x) ? query(x , lson) : query(x , rson);
    push_up(pos);
    return ans;
}

int main()
{
    //ios::sync_with_stdio(false);
#ifdef Online_Judge
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif // Online_Judge
    while(~scanf("%d%d%d" , &h , &w , &n))
    {
        if(h > n)h = n;
        build(1 , h , 1);
        while(n--)
        {
            int x;
            scanf("%d", &x);
            if(node[1] < x)printf("-1\n");x过大
            else printf("%d\n" , query(x , 1 , h , 1));
        }
    }
    return 0;
}



你可能感兴趣的:(线段树,ACM)