poj 1651 区间dp+矩阵连乘DP

http://poj.org/problem?id=1651

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
矩阵连乘相似题:http://blog.csdn.net/liufeng_king/article/details/8497607
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int N=105;
int a[N];
int dp[N][N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=n-2;i>0;i--)
            for(int j=i+2;j<=n;j++)
             {
                 int r=i+1;
                 int min=r;
                 for(int k=r;k<j;k++)
                     if(dp[i][k]+dp[k][j]+a[i]*a[j]*a[k]<=dp[i][min]+dp[min][j]+a[i]*a[j]*a[min])
                              min=k;
                 dp[i][j]=dp[i][min]+dp[min][j]+a[i]*a[j]*a[min];
             }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}


你可能感兴趣的:(poj 1651 区间dp+矩阵连乘DP)