poj2192(DFS)

Zipper
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14710   Accepted: 5221

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

Source

Pacific Northwest 2004
 
         本题要求前面两个串保持自己的相对顺序不变的情况下是否可以变化成第三个串。
      很容易想到这是一道搜索问题。首先第三个串的最后一个字符必是由前面两个中的一个的最后一个字符。倒数第二个又与除去刚才那个所剩的一样考虑。注意前两个的最后一个都和第三个相同时要考虑两种情况。本题倒着搜竖着搜都可以。
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN=200+10;
char a[MAXN],b[MAXN],c[MAXN*2];

bool DFS(int la,int lb)
{
	if(-1==la&&-1==lb)
		return true;
	if(la>=0&&a[la]==c[la+lb+1])
	if(DFS(la-1,lb))return true;//当a[la],b[lb]==c[lc]时,应考虑到两种情况
		//return DFS(la-1,lb);
	if(lb>=0&&b[lb]==c[la+lb+1])
		if(DFS(la,lb-1))return true;
	//	return DFS(la,lb-1);
	return false;
}

int main()
{
	int cas,tag=1;
	//freopen("in.txt","r",stdin);
	cin>>cas;
	while(cas--)
	{
		scanf("%s%s%s",a,b,c);
		int la=strlen(a)-1,lb=strlen(b)-1;
		bool flag=DFS(la,lb);
		if(flag)printf("Data set %d: yes\n",tag++);
		else printf("Data set %d: no\n",tag++);
	}
	return 0;
}

你可能感兴趣的:(搜索)