Big Number HDU1212

Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5448 Accepted Submission(s): 3783

Problem Description

As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output

For each test case, you have to ouput the result of A mod B.

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521

思路:1314%20 =(((((1%20)*10+3)%20*10+1)%20*10+4)%20)

#include<iostream>
#include<string.h>
#include<cstdio>


using namespace std;

int main ()
{
    char N1[1024] ={0};
    int nmod;

    while(scanf("%s%d",N1,&nmod) != EOF)
    {
       getchar();
        int len = strlen(N1);
        int ans =0;
        for(int i = 0; i <= len-1; i++)
        {
            ans = (N1[i] - '0'+ ans*10) % nmod;
        }

        printf("%d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(ACM,杭电)