A strange lift(2013.09.15)

F. A strange lift

Time Limit: 1000ms
Case Time Limit: 1000ms
Memory Limit: 32768KB
64-bit integer IO format:  %I64d      Java class name:  Main
Submit  Status  PID: 5746
Font Size:  +   -
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

BFS的裸题。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<ctype.h>
#include<cmath>
#include<queue>
#include<stack>
#define INF 1000000
using namespace std;
int n,a,b;
int lift[250]={0};
struct node
{
    int x,s;
};
int in(int x)
{
    if (x>0 && x<=n) return 1;
    return 0;
}
int bfs()
{
    if (a==b) return 0;
    int visit[250]={0};
    queue<node> q;
    node temp;
    temp.x=a;
    temp.s=0;
    visit[a]=1;
    int tx,ty;
    q.push(temp);
    node now;
    while(!q.empty())
    {
        node t=q.front();
        q.pop();
        if (t.x==b) return t.s;
        tx=t.x+lift[t.x];
        ty=t.x-lift[t.x];
        if (in(tx) && !visit[tx])
        {
            visit[tx]=1;
            now.x=tx;
            now.s=t.s+1;
            q.push(now);
        }
        if (in(ty) && !visit[ty])
        {
            visit[ty]=1;
            now.x=ty;
            now.s=t.s+1;
            q.push(now);
        }
    }
    return -1;

}
int main ()
{
    int i,j,k;
    while(scanf("%d",&n)!=EOF)
    {
        if (n==0) break;
        scanf("%d%d",&a,&b);
        for (i=1; i<=n; i++)
            scanf("%d",lift+i);
        int s=bfs();
        cout<<s<<endl;
    }
    return 0;
}


你可能感兴趣的:(bfs)