HDU 2066 一个人的旅行

Problem Description

虽然草儿是个路痴(就是在杭电待了一年多,居然还会在校园里迷路的人,汗~),但是草儿仍然很喜欢旅行,因为在旅途中 会遇见很多人(白马王子,^0^),很多事,还能丰富自己的阅历,还可以看美丽的风景……草儿想去很多地方,她想要去东京铁塔看夜景,去威尼斯看电影,去阳明山上看海芋,去纽约纯粹看雪景,去巴黎喝咖啡写信,去北京探望孟姜女……眼看寒假就快到了,这么一大段时间,可不能浪费啊,一定要给自己好好的放个假,可是也不能荒废了训练啊,所以草儿决定在要在最短的时间去一个自己想去的地方!因为草儿的家在一个小镇上,没有火车经过,所以她只能去邻近的城市坐火车(好可怜啊~)。

Input

输入数据有多组,每组的第一行是三个整数T,S和D,表示有T条路,和草儿家相邻的城市的有S个,草儿想去的地方有D个;
接着有T行,每行有三个整数a,b,time,表示a,b城市之间的车程是time小时;(1=<(a,b)<=1000;a,b 之间可能有多条路)
接着的第T+1行有S个数,表示和草儿家相连的城市;
接着的第T+2行有D个数,表示草儿想去地方。

Output

输出草儿能去某个喜欢的城市的最短时间。

Sample Input

6 2 3
1 3 5
1 4 7
2 8 12
3 8 4
4 9 12
9 10 2
1 2
8 9 10

Sample Output

9


简单最短路

#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<functional>
using namespace std;
const int maxn = 10005;
int n, m, x, y, z, dis[maxn], v[5 * maxn], Dis[maxn], ans;

struct abc
{
    int next, v;
    abc(){};
    abc(int a, int b) :next(a), v(b){};
};

vector<abc> tree[maxn];

struct cmp
{
    bool operator ()(const int &a, const int &b)
    {
        return dis[a] > dis[b];
    }
};

int dijkstra(int begin, int end)
{
    priority_queue<int, vector<int>, cmp> p;
    memset(dis, -1, sizeof(dis));
    dis[begin] = 0;
    p.push(begin);
    while (!p.empty())
    {
        int q = p.top();    p.pop();
        for (int i = 0, j; i < tree[q].size(); i++)
        {
            j = tree[q][i].next;
            if (dis[j] == -1 || dis[j]> dis[q] + v[tree[q][i].v])
            {
                dis[j] = dis[q] + v[tree[q][i].v];
                p.push(j);
            }
        }
    }
    return dis[end];
}

int main()
{
    int t;
    while (scanf("%d%d%d", &m, &n, &t) != EOF)
    {
        for (int i = v[0] = 0; i <= 1000; i++) tree[i].clear();
        for (int i = 1; i <= m; i++)
        {
            scanf("%d%d%d", &x, &y, &v[i]);
            tree[x].push_back(abc(y, i));
            tree[y].push_back(abc(x, i));
        }
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &x);
            tree[0].push_back(abc(x, 0));
        }
        dijkstra(0, n);
        int ans = 0x7FFFFFFF;
        for (int i = 0; i < t; i++)
        {
            scanf("%d", &x);
            if (dis[x] >= 0) ans = min(ans, dis[x]);
        }
        printf("%d\n", ans);
    }
    return 0;
}

你可能感兴趣的:(HDU)