hdu 1269 强连通图的判定

http://acm.hdu.edu.cn/showproblem.php?pid=1269

Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
 

Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
 

Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
 

Sample Input
   
   
   
   
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
 

Sample Output
   
   
   
   
Yes No
题目可以抽象为一个有向图的网络。如果想要任意两个点可以相互连通,则这个图网络为一个强连通图。所以解题思路就有了,求出该图的强连通分量的个数,如果唯一,这是强连通图,否则不是。

  裸题,直接贴模板就好了。

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int N=100005;//注意数组要开的够大
int head[N] ,ip,index,cnt_tar,top,stack[N],dfn[N],low[N],m,n,ins[N];
struct note
{
    int to;
    int next;
};
note edge[N];
void add(int u,int v)
{
    edge[ip].to=v;edge[ip].next=head[u];head[u]=ip++;
}
void tarjan(int u)
{
    int j,i,v;
    dfn[u]=low[u]=++index;
    stack[++top]=u;
    ins[u]=1;
    for(i=head[u];i!=-1;i=edge[i].next)
    {
        v=edge[i].to;
        if(!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(ins[v])
            low[u]=min(low[u],dfn[v]);
    }
    if(dfn[u]==low[u])
    {
        cnt_tar++;
        do
        {
            j=stack[top--];
            ins[j]=0;
        }
        while(j!=u);
    }
}
void solve()
{
    int i;
    top=0,index=0,cnt_tar=0;
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(ins,0,sizeof(ins));
    memset(stack,0,sizeof(stack));
    for(i=1;i<=n;i++)
    {
        if(!dfn[i])
        {
            tarjan(i);
        }
    }
    if(cnt_tar==1)
            printf("Yes\n");
        else
            printf("No\n");
}
int main()
{
    int u,v;
    while(~scanf("%d%d",&n,&m))
    {
        if(m==0&&n==0)
             break;
        memset(head,-1,sizeof(head));
        ip=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
        }
        solve();
    }
    return 0;
}

                                                                    


你可能感兴趣的:(hdu 1269 强连通图的判定)