暑假集训大一第五周周三赛 D - Rescue寻找路径


D - Rescue
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1242

Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 
 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 
 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input

      
      
      
      
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output

      
      
      
      
13


数据结构里面的优先队列,好好理清思路,好好研究

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
#include<stdio.h>
#include<queue>
using namespace std;
int x,y;
struct data
{
    int xx,yy,step;
    bool operator <(const data & t) const
    {
        return step>t.step;
    }
} st,pre;
int n,m,xx,yy,s[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
char a[1000][1000];
int BFS()
{
    priority_queue<data>que;
    st.xx=x,st.yy=y;
    st.step=0;
    que.push(st);
    a[x][y]='#';
    while(!que.empty())
    {
        st=que.top();
        que.pop();
        for(int i=0; i<4; i++)
        {
            xx=st.xx+s[i][0];
            yy=st.yy+s[i][1];
            if(xx>=0&&xx<n&&yy>=0&&yy<m&&a[xx][yy]!='#')
            {
                if(a[xx][yy]=='a')
                {
                    printf("%d\n",st.step+1);
                    return -1;
                }
                if(a[xx][yy]=='x')
                    pre.step=st.step+2;
                else
                    pre.step=st.step+1;
                pre.xx=xx;
                pre.yy=yy;
                que.push(pre);
                a[xx][yy]='#';
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<n; i++)
            scanf("%s",a[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                if(a[i][j]=='r')
                {
                    x=i;
                    y=j;
                    break;
                }
        int t=BFS();
        if(t!=-1)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}


你可能感兴趣的:(优先队列)